Issue
As more users are moving onto Revit 2021, we have noticed an influx of tickets regarding the "Your user license has expired and you are working within a grace period. There are 10 minutes remaining before the application will be closed." error message.
With the following error dialog box popping up:
Note: Autodesk has resolved this since writing of this article.
This incident has been resolved in:
Revit 2021.1.3
Revit 2022
Cause
Usually, this stems from linking in a file with the typical workflow we are used to. As soon as you link a file through the Manage Tab, it triggers a licensing error in the backend, and prompts for closing of the software.
Solution
It is currently (as of Mar 8, 2021) under investigation by the Autodesk Development Team, and we are awaiting a fix.
In the meantime, you can do the following:
- Link Differently
- Go to the Manage Tab -> Manage Links -> Click "Add" and add files that way
- Go to the Manage Tab -> Manage Links -> Click "Add" and add files that way
- Save and Close
- Just as the error message says, save/close, and then reopen and continue working.